ФЭНДОМ


Эта глава посвящена скриптам. А если точнее, она содержит общую информацию по скриптам. В идеале, эта глава предназначена для тех, кто разбирается в скриптовых языках (Java, C++, C#), или для тех, кто обладает опытом создания скриптов Neverwinter Nights. Как я уже говорил, это общая информация о скриптах, так как подробное описание создания скриптов заняло бы еще страниц 200, а это нам ни к чему. Поэтому я просто опишу пару примеров скриптов.


В "Ведьмаке" используется два скриптовых языка: LUA и Neverwinter Nights. В этой главе мы рассмотрим последние. Этот же скриптовый язык использовался в игре Neverwinter Nights. Естественно, эти скрипты можно писать в редакторе Д'жинни. В редакторе есть встроенный редактор скриптов, имеющий три основные функции: подсветка синтаксиса, нумерация строк и подсказки по синтаксису. Редактор скриптов можно запустить двумя способами. Первый: в меню Файл (File) выберите Создать ‐> Скрипт Neverwinter (.nss) (New‐>Neverwinter Script (.nss)).

Introduction scripting1


Откроется окно Новый скрипт neverwinter nights (new neverwinternights script).

Introduction scripting2


Это и есть редактор скриптов. Второй способ запустить его будет описан позже. Каждый скрипт необходимо скомпилировать или "перевести" в код, понятный компьютеру. Компиляцию скрипта можно проводить двумя способами. Первый способ: сохранить файл. При этом скрипт автоматически будет скомпилирован. Второй способ: выбрать пункт Компилировать (Compile) в меню Сервис (Tools).

Introduction scripting3


Пожалуйста, учтите, что пункт Компилировать (Compile) в меню Сервис (Tools) доступен только в том случае, если окно редактора скриптов активно. Кроме того, учтите, что при выборе этого пункта скрипт будет сначала сохранен, а потом скомпилирован.


Шаблон:Общая информация о скриптах