ФЭНДОМ


Мы добавили и присвоили файлы модулю, запустили сам модуль. Теперь нам необходимо протестировать его. Для чего? Прежде всего, для того, чтобы узнать, правильно ли он работает. Основная цель тестирования – найти возможные ошибки в модуле.


Для начала рекомендую вам немного пройтись. Подведите Геральта к тем местам, где должен быть Юз, главарь разбойников и волки. Что случилось? Никого нет? Есть только Зигфрид? Но почему? Неужели мы где‐то ошиблись?


Ответ: нет! Все в порядке. По умолчанию системы появления всегда отключены. Это не относится к системам появления NPC, поэтому Зигфрида мы видим сразу после запуска модуля. Наша первая задача – активировать соответствующие системы появления, чтобы игрок, запустивший наш модуль, видел всех необходимых персонажей. Включить и отключить систему появления можно двумя способами: с помощью скрипта или, что значительно проще, с помощью особого задания.


Этим мы займемся чуть позже, а пока нам необходимо несколькими способами проверить системы появления (мы же тестируем модуль, в конце концов). Откройте меню Отладка (Debug), которое появится после запуска модуля. В этом меню выберите Системы появления ‐> Системы появления модуля (Spawnsets ‐> Module Spawnsets).

R&TG037.png

В меню Системы появления модуля (Module Spawnsets) перечислены все системы появления, которые мы присвоили модулю. Напоминаю, что присвоение модулю файла и добавление файла в модуль – далеко не одно и то же. Сначала запустим систему появления Юза. Для этого в меню Отладка (Debug) выберите Системы появления ‐> Системы появления модуля ‐> nash_yuz (Spawnsets ‐> Module Spawnsets ‐> nasz_jozek). Через секунду Юз появится в своем пункте появления.

R&TG038.png


Откройте меню Отладка ‐> Системы появления ‐> Системы появления модуля (Debug ‐> Spawnsets ‐> Module Spawnsets).

R&TG039.png

Обратите внимание, что рядом с пунктом nash_yuz (nasz_jozek) появилась галочка. Это означает, что данная система появления включена. Если вы еще раз выберите пункт nash_yuz (nasz_jozek) в меню Отладка ‐> Системы появления ‐_______> Системы появления модуля (Debug ‐> Spawnsets ‐> Module Spawnsets), Юз исчезнет из модуля, и галочка рядом с пунктом снимется. Все пункты в меню Отладка (Debug) включаются и выключаются при их выборе. Естественно, вы можете включить все пункты в меню Отладка (Debug).


Выберите пункт Отключить все системы появления (Disable all spawnsets).

R&TG040.png


Все включенные ранее системы появления будут отключены.


Теперь давайте включим все системы появления, выбрав их в меню Отладка ‐> Системы появления ‐> Системы появления модуля (Debug ‐> Spawnsets ‐> Module Spawnsets).

R&TG041.png

Спустя пару мгновений все наши персонажи должны появиться в модуле. Системы появления можно включить и отключать с помощью заданий. Для этого достаточно выбрать действие Включить систему появления (Enable spawnset) или Выключить систему появления (Disable spawnset) в разделе Действия при завершении стадии (OnPhaseFinished Actions) или Действия при завершении задания (OnQuestFinished Actions). По этой причине мы можем усовершенствовать наше задание.


Каким образом? Главарь разбойников и его телохранители появятся в модуле только после того, как Геральт получит задание от Зигфрида. Зачем? Это поможет нам избежать путаницы с заданием. Например, что произойдет, если Геральт убьет главаря разбойников, не поговорив сначала с Зигфридом? С учетом такой возможности нам пришлось бы создавать новые реплики диалога. Однако мы добавили в наше задание вторую стадию, и благодаря этому мы сможем избежать вышеупомянутых осложнений.


Теперь мы знаем, как можно включить и отключить системы появления при тестировании модуля. Пока наш модуль запущен, мы можем проверить и остальные аспекты работы модуля. Чуть позже я опишу остальные пункты меню Отладка (Debug). А сейчас перейдем к окну обзора ресурсов (Resources Explorer). В этом окне есть несколько интересных команд, которые можно использовать при тестировании модуля. Если окно обзора ресурсов закрыто, откройте его, выбрав в меню Вид (View) Окна ‐> Обзор ресурсов (Utility Windows ‐> Resources Explorer).

R&TG042.png

В левой части экрана откроется окно обзора ресурсов (Resources Explorer). Раскройте ветвь Cutscenes, щелкнув по знаку плюса рядом с названием каталога. Щелкните правой кнопкой мыши по любому файлу с расширением .cut.

R&TG043.png

В контекстном меню вы увидите новый пункт Воспроизведение ролика (Play cutscene). Этот пункт доступен только в том случае, если запущен модуль. Он позволяет вам открыть ролик. Созданию роликов посвящена отдельная глава этого руководства.


Раскройте ветвь Scripts и щелкните правой кнопкой мыши по любому файлу с расширением .lua.

R&TG044.png

В этом меню также появился новый пункт. Команда Запуск файла (Play file) активирует скрипты, написанные на языке Lua. Если вы щелкните правой кнопкой мыши по файлу с расширением .nss, вы увидите в меню другой пункт.

R&TG045.png

Команда Запуск скрипта (Run scripts) запускает скрипт, написанный на языке Neverwinter Nights Script. Более подробно скрипты описаны в отдельной главе данного руководства.


Теперь раскройте ветвь Templates ‐> Characters, а затем раскройте, к примеру, ветвь NPC. Щелкните правой кнопкой мыши по любому файлу с расширением .utc. В меню появится раздел Отладка (Debug), а в нем – пункт Появление персонажа рядом с игроком (Spawn creature near player).

R&TG046.png

При выборе этого пункта указанный персонаж появится рядом с Геральтом (напоминаю, что utc‐файлы – это шаблоны персонажей). Это очень полезная команда.


Раскройте ветвь Templates ‐> Spawnsets ‐> Commoners и щелкните правой кнопкой мыши по любому файлу с расширением .spn. В разделе Отладка (Debug) появится новый пункт Выключить систему появления (Disable spawnset) или Включить систему появления (Enable spawnset).

R&TG047.png

Функция этой команды та же, что и у аналогичной команды в меню Отладка (Debug): она включает или отключает систему появления. Напоминаю, что spn‐файлы – это и есть системы появления.


На этом мы закончим разговор об окне обзора ресурсов (Resources Explorer). Учтите, что все вышеописанные команды доступны только в том случае, если модуль загружен.


Теперь вернемся к остальным пунктам меню Отладка (Debug). Выберите в меню пункт Задания (Quests).

R&TG048.png

Здесь вы увидите базу данных nasha_baza с заданием Поручение (nashe_zadanie.qst). Пункт Задания (Quests) в меню Отладка (Debug) позволяет протестировать задания. Выберите Поручение (nashe_zadanie.qst). Откроется окно Запуск задания: ПУСТО [только для чтения] (Running quest: EMPTY [Read Only]).

R&TG049.png

В этом окне вы увидите созданное нами задание, готовое к тестовому запуску. При тестировании это задание доступно только для чтения (то же самое указано в заголовке окна). Это означает, что изменить задание мы сейчас не сможем.


Обратите внимание, что блок Начало задания (Quest Beginning) выделен желтой рамкой. Это означает, что тестируемое задание находится на начальной стадии, но еще не является активным.

Вернитесь в модуль, щелкнув по закладке Игра (Game) в верхней части окна.

R&TG050.png

Теперь подойдите к Зигфриду и поговорите с ним. Согласитесь на задание, выбрав соответствующую реплику. После того, как вы примете задание Зигфрида, вернитесь к окну задания, щелкнув по закладке Запуск задания: ПУСТО [только для чтения] (Running quest: EMPTY [Read Only]).

R&TG051.png

Как видите, в окне произошли некоторые изменения.

R&TG052.png

Блок Начало задания (Quest Beginning) выделен зеленой рамкой. Это означает, что данная стадия задания была завершена. Теперь желтой рамкой отмечена стадия Главарь разбойников (Magister), что означает, что тестируемое задание находится на данной стадии. Если вы вернетесь в модуль, убьете Профессора, а затем выберете закладку задания, вы заметите, что стадия Главарь разбойников (Magister) завершена и отмечена зеленой рамкой. Тестирование перешло на стадию Зигфрид (Zygfryd), которая будет выделена желтой рамкой.

R&TG053.png

Если вы еще раз поговорите с Зигфридом и скажете, что вы убили Профессора, а затем вернетесь к закладке задания, вы увидите, что задание завершено, и блок Завершение задания (Quest Completed) выделен зеленой рамкой.

R&TG054.png

Это означает, что и диалог, и задание работают без ошибок. Позже мы внесем небольшие изменения, касающиеся появления главаря разбойников. А сейчас продолжим разговор об оставшихся пунктах меню Отладка (Debug).


􀂾 Режим бога (God Mode). Делает Геральта бессмертным. Очень полезно для тестирования боя. Если Геральт неуязвим, его не убьют, и вам не придется повторять тестирование.

􀂾 Отображать игровое время (Show game time). В левом нижнем углу экрана отображается текущее игровое время.

R&TG055.png

􀂾 Список убитых персонажей (Report current kill list). В журнале Aurora в нижней части экрана отображается список мертвых персонажей.

R&TG056.png

В этом списке отображается тег персонажа и количество убитых персонажей с таким тегом. Если окно журнала Aurora закрыто, в меню Вид (View) выберите Окна ‐> Журнал Aurora (Utility Windows ‐> Aurora Log).

R&TG057.png

􀂾 Отображать все записи дневника (Show all journal entries). В окне журнала Aurora отображаются все записи дневника Геральта.

R&TG058.png

􀂾 Отображать триггеры (Draw Triggers). Отображает триггеры в запущенном модуле.

􀂾 Отображать дальность восприятия (Show Perception Range). Отображает дальность восприятия всех появившихся в модуле персонажей.

R&TG059.png

Более подробно дальность восприятия описана в другой главе этого руководства.

􀂾 Отображать отношение к герою (Show Attitude To PC). Отображает отношение персонажа к Геральту. Для этого используется цветной круг у ног персонажа.

R&TG060.png

Зеленый круг означает, что персонаж настроен дружелюбно по отношению к Геральту, а красный круг означает, что персонаж относится к Геральту враждебно. Синий круг означает, что персонаж безразличен к Геральту. 􀂾 Отображать принадлежность (Show Affiliations). Отображает принадлежность персонажа к той или иной фракции. Принадлежность отображается в виде круга над головой персонажа.

R&TG061.png

Для персонажей, принадлежащих к одной фракции, используется один и тот же цвет круга.

􀂾 Отображать охраняемую зону (Show Guarded Zone). Отображает зону, охраняемую тем или иным персонажем. В нашем модуле ни один из персонажей такую роль не играет.

􀂾 Отображать пункты перехода (Show Waypoint). Отображает все пункты перехода. В нашем модуле пунктов перехода нет.

􀂾 Отображать личное пространство шфффччч(Show Personal Spaces). Отображает личное пространство, занимаемое персонажем. Для этого используется круг у ног персонажа.

R&TG062.png

􀂾 Отображать путь (Show Path Info). Отображает путь к области действия, к которой направляется персонаж.

R&TG063.png

􀂾 Отображать информацию (Show floating text). Отображает тестовую информацию о персонаже. Текст отображается над головой персонажа. Выбрав пункт Отображать информацию (Show floating text) в меню Отладка (Debug), вы можете указать тип информации.

R&TG064.png

Все команды в этом меню просто включаются и выключаются. Можно отобразить всю информацию сразу.

􀂾 Скрыть всю информацию (Hide all info). Скрывает всю тестовую информацию.

􀂾 Уровень и действия ИИ (AI level and Actions). Отображает информацию об уровне и действия ИИ.

R&TG065.png

􀂾 Расстояние в бою (Combat distances). Отображает расстояние между персонажами во время боя.

R&TG066.png

􀂾 Имя (Name). Отображает имя персонажа.

R&TG067.png

􀂾 Тег (Tag). Отображает тег персонажа.


R&TG068.png

􀂾 Информация о системе появления или NPC (Spawnset or NPC info). Отображает имя файла системы появления и текущую сюжетную стадию NPC.

R&TG069.png

􀂾 Действие персонажа (NPC Action info). Отображает действие, выполняемое персонажем в данный момент.

R&TG070.png

􀂾 Имя модели (Model Name). Отображает имя модели персонажа.

R&TG071.png

􀂾 Шаблон (Template). Отображает имя шаблона персонажа.

R&TG072.png

Последний пункт в меню Отладка (Debug) – Максимальное быстродействие (Best Performance). При выборе этого пункта уровень графических эффектов в модуле будет снижен до минимума. Это поможет достичь максимального быстродействия при тестировании. Это очень полезная команда.


Вот и все, что касается меню Отладка (Debug). Теперь перейдем к последнему средству тестирования модулей, а именно к Инспектору игровых объектов (Game Object Inspector). Чтобы открыть это окно, в меню Вид (View) выберите Окна ‐> Инспектор игровых объектов (Utility Windows ‐> Game Object Inspector).

R&TG073.png

В левой части экрана откроется окно Инспектор игровых объектов (Game Object Inspector).

R&TG074.png

В этом окне отображается все необходимая информация о том, что происходит в тестируемом модуле. Информация отображается в виде древовидной схемы. Раскройте ветви NPC и Системы появления (Spawnsets), щелкнув по знаку плюса рядом с их названиями.

R&TG075.png

В ветви NPC отображается информация обо всех NPC в запущенном модуле. В нашем случае есть только один NPC, т. е. Зигфрид. Напоминаю, что его систему появления мы сохранили в файле nash_zygfryd.npc (nasz_zygfryd.npc). Раскройте эту ветвь.

R&TG076.png

Здесь отображается следующая информация:

− Стадия сюжета (Story phase). Текущая сюжетная стадия NPC;

− Стадия появления (Spawn phase). Текущая стадия появления NPC;

− Диалог (Conversation). Диалог, присвоенный NPC;

− Шаблон (Template). Имя шаблона персонажа;

− Управление системой ИИ (AI system control). Указывает, управляется ли данный персонаж компьютером (true) или игроком (false).


Щелкните правой кнопкой мыши по ветви nash_zygfryd (nasz_zygfryd) и выберите пункт Открыть в редакторе (Open in editor).

R&TG077.png

Откроется система появления Зигфрида. Щелкнув правой кнопкой мыши по другим ветвям, вы увидите в меню дополнительные команды. К примеру, щелкните правой кнопкой мыши по пункту Стадия сюжета (Story phase) и выберите в меню команду Изменить (Modify).

R&TG078.png

Откроется окно Выберите новую стадию сюжета (Select new story phase window), в котором вы можете изменить текущую сюжетную стадию персонажа. В нашем случае это сделать невозможно, так как мы создали только одну сюжетную стадию для Зигфрида – zadanie (zlecenie).

Теперь щелкните правой кнопкой мыши по пункту Диалог (Conversation) и выберите пункт Открыть в редакторе (Open in editor).

R&TG079.png

Откроется файл диалога.


Пункт Обновить вид (Refresh view) обновит содержимое окна Инспектор игровых объектов (Game Object Inspector). Пункт Удалить всех персонажей (Remove all creatures) позволяет удалить всех персонажей из окна Инспектор игровых объектов (Game Object Inspector). Это означает, что проверка персонажей больше не будет проводиться в этом окне.


Раскроем подветвь nash_zygfryd (nasz_zygfryd). Эти данные относятся к тегу Зигфрида. Здесь отображается следующая информация.

R&TG080.png

В окне отображается много ветвей. Они содержат информацию практически по всем темам, начиная со здоровья и энергии персонажа и заканчивая его характеристиками и профилями. Чтобы просмотреть точные данные, раскройте соответствующую ветвь.


При щелчке правой кнопкой мыши по подветви открывается меню, которое содержит такие пункты, как Изменить значение (Modify value) и т. п. Теперь щелкните правой кнопкой мыши по ветви с тегом Зигфрида и выберите пункт Телепортировать сюда игрока (Teleport player nearby).

R&TG081.png

Геральт будет перенесен к Зигфриду. Эта функция позволяет сэкономить время, сразу перенося игрока к соответствующему персонажу. Теперь выберите в меню пункт Релевантные файлы (Relevant files).

R&TG082.png

Откроется список всех файлов, связанных с выбранным персонажем.

R&TG083.png

Вы можете открыть любой из этих файлов, выбрав его в меню.


Теперь вернемся к ветви Системы появления (Spawnsets). Раскройте ветвь nash_yuz (nasz_jozek), имя которой соответствует имения файла с системой появления Юза.

R&TG084.png

Вы увидите подветвь poker. Напоминаю, что poker – имя элемента появления в системе параметров Юза. Раскройте ветвь poker. Здесь отображается дополнительная информация о Юзе.

R&TG085.png

− Ячейки (Slots). Количество персонажей, которые появятся в игре;

− Появилось (Spawned). Количество персонажей, которые уже появились;

− Время до следующего появления (Time to next spawn). Оставшееся время до следующего появления;

− Убито (Killed). Количество убитых персонажей.


Теперь щелкните правой кнопкой мыши по ветви nash_yuz (nasz_jozek) и выберите пункт Открыть в редакторе (Open in editor).

R&TG086.png

Откроется система появления Юза. Щелкнув правой кнопкой мыши по ветви poker и выбрав пункт Открыть в редакторе (Open in editor), вы откроете шаблон Юза.


Теперь сделайте так, чтобы Геральт увидел одного из второстепенных персонажей (не NPC). Пусть это будет Юз. Теперь нажмите кнопку Добавить видимых персонажей (Add Visible Creatures) в верхней части окна Инспектор игровых объектов (Game Object Inspector).

R&TG087.png

В ветви Видимые персонажи (Visible creatures) будут созданы новые подветви со списком персонажей, видимых на экране.

R&TG088.png

Здесь вы получите доступ к тем же данным, что мы рассматривали для NPC.


На этом наш разговор о тестировании модуля практически завершен. Но есть еще пара трюков, о которых мне хотелось бы вам рассказать. Наведите курсор на персонажа и нажмите клавишу Y, чтобы убить персонажа. Нажмите Shift+Y, чтобы убить всех персонажей в районе курсора. Но учтите, что NPC убить невозможно. Чтобы мгновенно переместить Геральта в ту или иную область, наведите курсор на пункт назначения и нажмите клавишу "+" на цифровой клавиатуре.


А теперь давайте займемся изменениями, о которых упоминалось выше. Сначала нам необходимо изменить задание, чтобы Профессор и его телохранители появлялись в игре после того, как Геральт согласится на задание Зигфрида. Как я уже говорил, после того, как мы добавили файл в модуль, все изменения необходимо производить в окне обзора модуля (Module Explorer). Если это окно закрыто, в меню Вид (View) выберите Окна ‐> Обзор модуля (Utility Windows ‐> Module Explorer).

R&TG089.png

В левой части экрана откроется окно обзора модуля (Module Explorer).

R&TG090.png

Раскройте ветвь Описание заданий (Quest Definitions), щелкнув по знаку плюса рядом с ее именем. Затем дважды щелкните по пункту nasha_baza (nasza_baza).

R&TG091.png

Откроется окно обзора заданий (Quests Explorer) с нашей базой данных.

R&TG092.png

Дважды щелкните по строке с нашим заданием.

R&TG093.png

Откроется окно nashe_zadanie.qst (nasze_zadanie.qst).

R&TG094.png

Теперь необходимо внести вышеупомянутые изменения. Откройте окно свойств. Для этого в меню Вид (View) выберите Окна ‐> Свойства (Utility Windows ‐> Properties).

R&TG095.png

В правой части экрана откроется окно свойств (Properties). Теперь выберите блок Начало задания (Quest Beginning).

R&TG096.png

Теперь перейдите в окно свойств (Properties). Внесем изменения в раздел Действия при завершении стадии (OnPhaseFinished Actions).

R&TG097.png

Почему именно в этот раздел? Потому что действия, указанные в разделе Действия при завершении стадии (OnPhaseFinished Actions), выполняются после завершения соответствующей стадии. В нашем случае стадия Начало задания (Quest Beginning) отвечает за действия, выполняемые после того, как Геральт согласится на задание Зигфрида. Щелкните по правой ячейке параметра Доступные действия (Available actions) и выберите в списке значений пункт Включить систему появления (Enable spawnset).

R&TG098.png

Затем щелкните по синему знаку плюса.

R&TG099.png

Действие Включить систему появления (Enable spawnset) будет добавлено в раздел Действия при завершении стадии (OnPhaseFinished Actions).

R&TG100.png

Теперь щелкните по желтой иконке в правой ячейке параметра spn_resref.

R&TG101.png

R&TG102.png

Откроется стандартное окно Windows для загрузки файлов. Откройте систему появления Профессора, главаря разбойников. Перейдите в каталог Data\Templates\Spawnsets\Enemies, в котором мы сохранили систему появления. Выберите файл nash_professor.spn (nasz_magister.spn) и нажмите кнопку Открыть. Система появления nash_professor.spn (nasz_magister.spn) будет указана в значении параметра spn_resref.


R&TG103.png

Теперь необходимо сделать то же самое для телохранителей Профессора. Для каждого из них добавьте действие Включить систему появления (Enable spawnset) в раздел Действия при завершении стадии (OnPhaseFinished Actions). Щелкните по желтой иконке в правой ячейке параметра spn_resref и выберите файл nash_razboynik.spn (nasz_bandyta.spn).

R&TG104.png

Вот и все. Мы внесли все необходимые изменения, и теперь осталось лишь их сохранить. Необходимо сохранить обновленные действия и модуль. Начнем с задания. В меню Файл (File) выберите пункт Сохранить nashe_zadanie.qst (Save nasze_zadanie.qst).

R&TG105.png

Если в меню нет пункта Сохранить nashe_zadanie.qst (Save nasze_zadanie.qst) или в нем указано другое имя файла, это, возможно, означает, что окно nashe_zadanie.qst (nasze_zadanie.qst) в данный момент не является активным. Чтобы активировать окно, щелкните по его заголовку, а затем выберите в меню Файл (File) пункт Сохранить nashe_zadanie.qst (Save nasze_zadanie.qst). Теперь сохраните модуль. Для этого в меню Модуль (Module) выберите пункт Сохранить модуль (Save Module).

R&TG106.png

Однако нам необходимо создать еще одно задание. Это будет так называемое "инициирующее задание", которое активируется вместе с модулем при запуске игры. Естественно, игрок даже не узнает о существовании этого задания, т. к. основная его цель – включить необходимые системы появления персонажей.


Сейчас я расскажу вам, как создать особое задание, которое будет автоматически добавлено в базу данных заданий. Перейдите в окно обзора заданий (Quest Explorer). Щелкните правой кнопкой мыши по любой строке и выберите пункт Добавить новое задание ‐> nasha_baza (Add New Quest To ‐> nasza_baza).

R&TG107.png

Откроется стандартное окно Windows для сохранения файлов. Перейдите в каталог Data\Quests, введите имя файла nash_init (nasze_init) и нажмите кнопку Сохранить. Откроется окно Введите имя задания (Enter Quest Name).

R&TG108.png

В поле Имя (Name) введите имя задания initialization и нажмите кнопку OK. Задание initialization будет автоматически добавлено в нашу базу данных.

R&TG109.png

Дважды щелкните по новому заданию.

R&TG110.png

Откроется окно nash_init.qst (nasze_init.qst).

R&TG111.png

Так как это задание используется просто для начала нашего приключения, нам не нужно переименовывать стадии и т. п. Но в задании должна быть одна условная стадия. Щелкните правой кнопкой мыши по блоку Начало задания (Quest Beginning) и выберите пункт Вставить стадию ‐> Условная стадия (Insert Phase ‐> Conditional Phase).

R&TG112.png

Откроется окно Введите имя (Enter name). Оставьте значение, предложенное по умолчанию, и нажмите кнопку OK. Теперь перейдите в окно свойств (Properties) и откройте раздел Действия при завершении стадии (OnPhaseFinished Actions). Так как стадии Начало задания (Quest Beginning) не присвоено ни одного действия, задание активируется при загрузке модуля. Все действия, перечисленные в разделе Действия при завершении стадии (OnPhaseFinished Actions) будут выполнены автоматически.


Это задание используется только для включения стадии появления Юза и волков. Щелкните по правой ячейке параметра Доступные действия (Available actions) в разделе Действия при завершении стадии (OnPhaseFinished Actions). Выберите Включить систему появления (Enable spawnset) и щелкните по синему знаку плюса рядом с выбранным действием.

R&TG113.png

Теперь щелкните по желтой иконке в правой ячейке параметра spn_resref. Откроется стандартное окно Windows для загрузки файлов. Перейдите в каталог Data\Templates\Spawnsets\Commoners, выберите файл nash_yuz.spn (nasz_jozek.spn) и нажмите кнопку Открыть.

R&TG114.png

Файл nash_yuz.spn (nasz_jozek.spn) будет присвоен параметру spn_resref.


Необходимо добавить еще одно действие Включить систему появления (Enable spawnset) для волков. После этого в значении параметра spn_resref выберите файл nash_volk.spn (nasz_wilk.spn) из каталога Data\Templates\Spawnsets\Enemies.

R&TG115.png

С этим заданием мы закончили. Не забудьте сохранить изменения. Откройте меню Файл (File) и выберите пункт Сохранить nash_init.qst (Save nasze_init.qst).

R&TG116.png

Если в меню нет пункта Сохранить nash_init.qst (Save nasze_init.qst) или в нем указано другое имя файла, это, возможно, означает, что окно nash_init.qst (nasze_init.qst) в данный момент не является активным. Чтобы активировать окно, щелкните по его заголовку, а затем выберите в меню Файл (File) пункт Сохранить nash_init.qst (Save nasze_init.qst). Вот и все.


На этом мы завершаем очередной этап создания нашего модуля. Теперь все готово, и наш модуль отлично работает. Если вы внимательно читали это руководство, вы теперь способны самостоятельно создать собственный модуль. Не расстраивайтесь, если ваши первые модули будут относительно простыми. Со временем вы наберетесь достаточно опыта работы в редакторе D’jinni, и уровень вашего мастерства неизменно возрастет.


В следующей главе мы рассмотрим более сложные аспекты работы в редакторе, такие как создание роликов, спецэффектов и скриптов.

Обнаружено использование расширения AdBlock.


Викия — это свободный ресурс, который существует и развивается за счёт рекламы. Для блокирующих рекламу пользователей мы предоставляем модифицированную версию сайта.

Викия не будет доступна для последующих модификаций. Если вы желаете продолжать работать со страницей, то, пожалуйста, отключите расширение для блокировки рекламы.

Также на ФЭНДОМЕ

Случайная вики